博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
zju 1005 zoj 1005
阅读量:4120 次
发布时间:2019-05-25

本文共 2558 字,大约阅读时间需要 8 分钟。

Jugs

Time Limit: 2 Seconds     
Memory Limit: 65536 KB     
Special Judge

In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A

fill B
empty A
empty B
pour A B
pour B A
success

where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.

Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 45 7 3

Sample Output

fill Bpour B Aempty Apour B Afill Bpour B Asuccessfill Apour A Bfill Apour A Bempty Bpour A Bsuccess

这题我被唬了半天,后来查了下资料,发现原来不管只灌A还是只灌B都是行的,而且答案不止一个,英语不好的悲哀啊

#include<stdio.h>

int main(){
    int a,b,watera,waterb,n;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF){
        watera=0,waterb=0;
        while(watera!=n&&waterb!=n){
            if(watera==0){
                printf("fill A\n");
                watera=a;
                continue;
            }
            if(waterb==b){
                printf("empty B\n");
                waterb=0;
                continue;
            }
            if(watera!=0){
                if(watera<=b-waterb) waterb+=watera,watera=0;
                else watera-=b-waterb,waterb=b;
                printf("pour A B\n");
                continue;
            }
        }
        printf("success\n");
    }
    return 0;
}

转载地址:http://mxtpi.baihongyu.com/

你可能感兴趣的文章
Linux查看mac地址
查看>>
Linux修改ip
查看>>
MySQL字段类型的选择与MySQL的查询效率
查看>>
Java的Properties配置文件用法【续】
查看>>
JAVA操作properties文件的代码实例
查看>>
IPS开发手记【一】
查看>>
Java通用字符处理类
查看>>
文件上传时生成“日期+随机数”式文件名前缀的Java代码
查看>>
Java代码检查工具Checkstyle常见输出结果
查看>>
北京十大情人分手圣地
查看>>
Android自动关机代码
查看>>
Android中启动其他Activity并返回结果
查看>>
2009年33所高校被暂停或被限制招生
查看>>
GlassFish 部署及应用入门
查看>>
iWatch报错: Authorization request cancled
查看>>
iWatch报错: Authorizationsession time out
查看>>
如何运行从网上下载的iWatch项目详细步骤.
查看>>
X-code7 beta error: warning: Is a directory
查看>>
Error: An App ID with identifier "*****" is not avaliable. Please enter a different string.
查看>>
X-code beta 开发iWatch项目,运行没有错误,但是某些操作一点就崩,而且找不错误的原因场景一
查看>>